Canreef Aquatics Bulletin Board  

Go Back   Canreef Aquatics Bulletin Board > General > Product Review and Equipment Forum > Filtration and Skimmer Specific

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2015, 12:13 AM
Deep_azul Deep_azul is offline
Junior Member
 
Join Date: Nov 2014
Location: Chilliwack, BC
Posts: 5
Deep_azul is on a distinguished road
Angry Deltec MC500 on a RSM 250

Hey all, does anyone have experience with the Deltec 500? I have heard so many good things about this skimmer but I can't get this thing running propperly. I seem to have to re-adjust it every time I shut the pumps down to feed, or if I just look at it sideways. Any tips, suggestions would be appreciated.
Reply With Quote
  #2  
Old 11-11-2021, 04:48 PM
Rogue951 Rogue951 is offline
Member
 
Join Date: Feb 2010
Location: East Vancouver
Posts: 388
Rogue951 is on a distinguished road
Default

I had a 500 (thats the in sump one right?).
Upgraded to 600 HOB.
but I never had a problem with it running. very forgiving actually. Throw it in the sump, ran it with air valve full open, and adjusted the cup to where I wanted it.
have you had it long?
Maybe its just pulling out a lot of crap until it settles down.
It is a very strong skimmer.

Word of warning. I had a hell of a time finding a new pump for my MCE600.
None of deltec's North american distributors could help me.
ended up ordering a Red Dragon SP3 from china on ebay.



bahaha ok so I didn't realize the equipment thread moved so slowly and this is from years ago.
my bad.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 08:34 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.