PDA

View Full Version : Xm 20k not blue?


2bafish
11-05-2012, 01:24 AM
Yesterday i bought 3 new xm 20k halide bulbs, 250 watt DE. I used to use 14k phoenix bulbs. I bought these xm 20k bulbs because i wanted more blue. Unfortunately they are not. Its more of a white with blue tint. I use vertex electronic ballasts. Could that be the reason?

2bafish
11-06-2012, 02:06 AM
I am returning the xm bulbs. I am thinking of going with giesemann 20k bulbs.. Anyone have experience with them?

Proteus
11-06-2012, 03:23 AM
I used geissmenn. 21k. Really liked them. Aqua medic is good also

Northernseacorals
11-06-2012, 03:27 AM
I am returning the xm bulbs. I am thinking of going with giesemann 20k bulbs.. Anyone have experience with them?

Like you I did not like XM bulbs at all; right now I am using Pheonix bulbs and like the colour very much.

lastlight
11-06-2012, 04:34 AM
most consider a phoenix to already be closer to 20k than 14k.

And as far as I know most bulbs will fire bluer on electronics so switching ballasts likely won't help you.

kien
11-06-2012, 04:50 AM
most consider a phoenix to already be closer to 20k than 14k.

And as far as I know most bulbs will fire bluer on electronics so switching ballasts likely won't help you.

For an LED guy you sure know a lot about halides :-)

I had a problem with one of my ballasts (250w galaxy) earlier this year and it fired a 14K bulb much closer to a yellow 10K. Very noticeable when seen side by side with the other bulbs. At first i thought it was the bulb so my knee jerk reaction was to replace the bulb. Same problem with a new bulb tho. I replaced the ballast and it was fine after that. So ya, the moral of this story is that it could be a ballast issue.