PDA

View Full Version : 34gal red sea max


flipzed
10-29-2010, 03:47 PM
so im having a hard time keeping my nitrates down... i dont over feed the fish. its running on a stevie t media rack and tunze skimmer,... and my reading for nitrate is allways 20. no mater how many water changes i do i cant get it to come down to 10-5. ive been doing water changes about once a week.anyone have any idea what else i can try.. i mean my corals and fish look fine and are happy. but id like to bring it down a touch just to be safe..

Sean
10-29-2010, 08:10 PM
I'm having a simmilar problem with my 28g nano cube, one thing that helped was cleaning the pumps. That's something I forget to clean on a regular basis and you will be suprised how much crap get stuck on it. Those all in ones are tricky as everything is tucked away and you can forget about the small things. If you haven't cleaned them in awhile give that a try. It won't fix your problem but it won't hurt.

Sorry this isn't a complete fix ;)

flipzed
10-30-2010, 06:21 PM
yaa ive sucked out all the gross stuff that builds up at the bottom of the tank in the rear compartment under the skimmer, cleaned out all the live rock and carbon in the media rack, dosnt look like theres much crap or anything on the sand in the display part of the tank. everything else looks clean so idk what else to do...

Smudge
10-30-2010, 06:46 PM
What are your stocking levels?

flipzed
10-30-2010, 06:59 PM
2 shrimp, 2 baby clowns, 2 baby cardinals, flame angel, and a bi color basselet and a starfish, tube anemone. and prolly about 30 lbs of live rock so its not overcrowded

Rymah
11-12-2010, 07:13 PM
i had the same problem for a while, what test kit are you using?
the API test kit expires after 3 years and gives high readings, i thought i had a nitrate problem, i would check before w/c after w/c the ro water EVERYTHING was showing 20ppm nitrate got a new test.... there at 2.5ppm except my r/o water... its clear..

they way to check- there will be a code on your bottle the last 4 digits at the month and year the product was botteld i found with mine it was botteled in 2007 and i diddnt buy it until 2008 so if you have had the kit for awhile it may be that.. take your water to your LFS and ask them to check it for you.

flipzed
11-13-2010, 05:46 PM
im using the api test.. i just bought it like 6 months ago... ill have to check the dates on it when i get home.. im gonna cut back on the feeding a bit too i think. as right now im feeding a cube a day part in the morn and part before lights out. see if that helps maybe. not sure what these bio pellets are that people are talking about ill have to look into that too.