PDA

View Full Version : help and suggestions


kdpuffer
06-17-2008, 02:22 AM
hey there i have a 29 gallon biocube and am having some mad algae out breaks i have hair algae red slime you name it and it seems to be growing what can i do about it the tank was established when i got it and they had the same problem help please my tank looks like crap.

super7
06-17-2008, 02:33 AM
whats the water chemistry, how long are the lights on for?
Super7

crtrcrzy
06-17-2008, 02:46 AM
had a similar problem once it was more a water flow problem than any thing .slow current gives the algae a chance to ghrow also how old are your lights ,usually the bulbs are good for a year before loosing thier uv spectrum effectiveness

Der_Iron_Chef
06-17-2008, 03:04 AM
Hey dude, what water are you using?

crtrcrzy
06-17-2008, 03:41 AM
Hey dude, what water are you using?

good point i switched to an rodi unit also

mark
06-17-2008, 03:58 AM
how much you feeding, skimmer, doing water changes? algae don't grow from nothing

ponokareefer
06-17-2008, 04:21 AM
Make sure you add additional flow to these all-in-one systems, as they never have enough. If it don't have a protein skimmer, this is also a must. Finally, what do you have all in the system? If the system is overstocked, no matter how much flow and a good protein skimmer you have, you will run into problems.

bignose
06-17-2008, 05:24 AM
I have the same problem. I bumped up the circulation and added some turbo snails. It seems to be helping quite a bit.